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Most Common Image File Formats



BMP Files



BMP (Bitmap Picture) File Format

• Raster graphics image file format created in 1994

• Stores bitmap digital images independent of display device

• Primarily used on Windows and OS/2

• Characteristics
• Does not support effective image compression

• Translate well to dot-format output devices like CRTs and printers

• Large and uncompressed; rich in color, high in quality

• Best use: Print graphics



GIF Files



GIF (Graphics Interchange Format) File Format

• Commonly used for web images and sprites in software 
programs

• Created by Steve Wilhite at CompuServe (1987) for video display 
@ dial-up modem speeds

• Characteristics
• Uses a maximum of 256 colors
• Fewer available colors, so smaller than JPEG
• Lossless LZW compression

• Best uses: Line drawings, simple illustrations, animations, web 
graphics and small icons



JPG Files



JPEG (Joint Photographic Experts Group) Format

• Common file format (created in 1992) for digital photos and 
other digital graphics

• Uses lossy compression (image quality lost as file size decreases)

• Characteristics
• Standard format for most digital cameras

• Great for making smaller file sizes / images with more than 256 colors

• Compatible across nearly all devices and platforms (including the web)

• Best uses: Black and white images, images with complex 
coloring, still life imagery, real life photographs



PNG Files



PNG (Portable Network Graphics) File Format

• Raster graphics format (created in 1996) as an improved, non-patented 
replacement for GIFs

• Most used lossless image compression format on internet
• Two types of PNG image formats

• PNG-8
• Similar to GIF (but smaller)
• 256 colors and 1-bit transparency

• PNG-24
• 24-bit color (similar to JPEG)
• Can include over 16 million colors
• Lossless compression means larger files than JPEG

• Best uses: Web images and logos, transparent or semitransparent images, 
complex images like photographs if file size is not an issue



Exporting Images to PNG vs. JPEG

Original RAW File (6000x4000): 28MB

JPEG Export (100% Quality): 9.7MB PNG-24 Export: 18.6MB



PSD Files



PSD (Photoshop Document) File Format

• Image file format native to Photoshop; works with Adobe products

• Supports multiple pictures, objects, filters, text, as well as using 
layers, vector paths and shapes, and transparency

• Commonly used for containing high quality graphics data

• Characteristics
• Capable of holding 30,000 pixels in both height and width

• File size can extend to 2GB

• Best uses: Images that will be sent to print, images that are being 
edited and layers are needed, high quality digital photography



PSB (Photoshop Big) File Format

• Files with .PSB extension are Adobe Photoshop Large 
Document files

• Nearly identical to more common PSD format

• PSB files support much larger files
• Can be as large as 4 EB (over 4.2 billion GB)

• Supports height and width up 300,000 pixels

• PSDs are limited to 2 GB and image dimensions of 30,000 pixels



TIFF Files



TIFF (Tagged Image Format File) File Format

• Created in 1986 by Aldus Corporation as a common file format for 
scanned images

• Patent acquired by Adobe Systems in 2009

• Commonly used for high quality graphics

• Characteristics
• Can be viewed/edited in nearly all photo editing software products
• Whether compressed or not, TIFFs do not lose any image data
• Preferred format for scanning photographs and other complex imagery

• Best uses: Images that will be sent to print, images that are being 
edited and layers are needed, high quality digital photography



Image Format Comparison Chart
JPG TIFF PNG GIF BMP PSD

Lossy compression

Lossless compression

Uncompressed option

Grayscale

RGB Color

8-bit color (24-bit data)

16-bit color option

CMYK or LAB color

Indexed color option

Transparency option

Animation option

Layers

Print or Web Both Print Web Web Print Print



Roundtripping with 
Lightroom Classic



Why Roundtrip?

• Lightroom cannot do everything

• There are times you want to send a photo to Photoshop

• Go to Photoshop to use layers and filters

• Common to use Photoshop for
• Retouching

• Dodging and burning

• Layered composites

• Special effects

• Best to make your main adjustments in Lightroom first



Better File Choice – TIFF or PSD?

• Both TIFF and PSD files are lossless; quality factor is the same

• TIFFs are MUCH larger in size than PSD files

• TIFFs do not (generally) offer photographers a significant 
advantage

• Exception: If you are sharing your file with someone using a 
program that doesn’t accept PSD files

• In this presentation, all LR-PS examples will use PSD files



How to Specify TIFF or PSD



Simple Roundtrip Workflow

1. Open Lightroom Classic 

2. Select the desired photo in the Lightroom catalog (Library, Develop, 
Slideshow, or Print modules)

3. Perform desired Lightroom edits

4. Right-click on the selected photo and send it to Photoshop as a 
Smart Object

5. Perform desired Photoshop edits

6. When finished, save the file to return it to Lightroom

7. File with Photoshop edits now in Lightroom catalog



Opening a Lightroom Photo in 
Photoshop for the First Time



Perform Initial Edits in Lightroom



Send to Photoshop as a Smart Object



File Opens in Photoshop



File Opens in Photoshop



RAW File Opens in Adobe Camera Raw



Lightroom Settings Are Intact



Make Further Changes in Camera Raw



Updated File Returns to Photoshop



Save the Updated File



File Returns to Lightroom



File Returns to Lightroom



New PSD File in Lightroom Catalog



Go Back to Photoshop / Make More Changes



Save the Updated File



File Returns in Place to Lightroom



Opening a Photoshop Image From 
Lightroom



Send File to Photoshop (NOT a Smart Object)



Edit the ORIGINAL File – NOT a Copy



File Opens in Photoshop With Layers Intact



Opening a Photoshop Image With 
Lightroom Adjustments Applied



Add a Lightroom Adjustment to the PSD File



Send Edited File to Photoshop



Edit the ORIGINAL File – NOT a Copy



PSD File Does Not Reflect Lightroom Changes



Make Additional Changes in Photoshop



Return to Lightroom



Keeping Lightroom Adjustments in 
Photoshop



Send the File to Photoshop



Edit a COPY of the File – With Adjustments



Photoshop File Reflects Lightroom Changes



Transferring Lightroom 
Adjustments to Photoshop



Send the File to Photoshop



Edit a COPY of the File



File Opens in Photoshop With Layers Intact



Third Copy of File Now in Lightroom Catalog



Create Preset to Store Lightroom Adjustments



Create Preset to Store Lightroom Adjustments



Open Original File in Camera Raw



Original RAW File in Camera Raw



Apply Preset Created in Lightroom



Photoshop File Updated with Lightroom Preset



Quick Summary of LR-PS Roundtripping
• Make initial adjustments in Lightroom

• Right-click, Edit in> Open as a Smart Object in Photoshop. Apply 
Photoshop adjustments and choose Save

• If you want to work on that Photoshop Layered File again, choose Edit 
In>Open in Photoshop (Edit Original)

• If you want to change the RAW settings, its best to open the Smart Object 
in Photoshop

• However, if you make changes in Lightroom to the Photoshop image…
• If you want to keep the Lightroom adjustments (those made after you bring the 

images back from Photoshop) choose Edit In>Open in Photoshop (Edit a Copy with 
Lightroom Adjustments)

• If you want to create a copy of the Photoshop file and preserve the original, choose 
Edit In>Open in Photoshop (Edit a Copy with Lightroom Adjustments)



Opening a Lightroom Photo in a 
Plugin



Perform Basic Edits in Lightroom



Send the File to the Desired Plugin



Choose Copy File Options; Click Edit



Make Desired Edits With Plugin



Click Apply to Export File Back to Lightroom



Edited TIFF File Now in Lightroom Catalog



Quick Summary of LR-Plugin Roundtripping

•Make initial adjustments in Lightroom

•Right-click, Edit in>Plugin Name

•Choose Edit a Copy with Lightroom Adjustments

• Specify the desired Copy File Options

•Perform desired edits in the plugin application

•Apply the changes in the plugin to return edited file to 
Lightroom



Questions



Supplemental Materials



Setting Up An Effective LR-PS Workflow

• Certain settings in both programs are needed to establish the proper 
workflow

• To send photos from Lightroom to Photoshop, go to 
Lightroom>Preferences>External Editing and make the following 
changes
• Format to PSD (because they are smaller than TIFF files)

• Color Space to ProPhoto (or Adobe RGB if required).

• Bit Depth to 16

• Resolution to 240



Setting Up An Effective LR-PS Workflow

• To properly receive images in Photoshop from Lightroom, go to 
Photoshop>Edit>Color Settings and make the following changes
• Under Working Spaces, select the color space you set in Lightroom (ProPhoto

or Adobe RGB)

• Under Color Management Policies, select Preserve Embedded Profiles from 
the RGB menu

• Enable Missing Profiles: Ask When Opening

• To properly send the PSD file back to Lightroom, go to 
Photoshop>Preferences>File Handling and select Always from the 
Maximize PSD and PSB File Compatibility menu.



Lightroom and Photoshop Roundtrip Workflow

• Now that the environment has been set up properly, you can 
roundtrip from Lightroom to Photoshop in the following steps:
• Right-click on any photo in Lightroom and select Edit In>Open as Smart 

Object in Photoshop

• Perform your changes in Photoshop

• Select File>Save. If you select File>Save As, the resulting file will have to be 
imported into the Lightroom Catalog to be visible

• Make sure you are saving in PSD format

• Go back to Lightroom and you will see the PSD file next to the RAW file you 
had originally sent over

• Change Sort Order to Capture Time if you do not see it



Lightroom and Photoshop Roundtrip Workflow

• To retroactively change your RAW file in Lightroom and apply those 
changes to the same image in an existing Photoshop document (thus 
keeping your Lightroom image updated with its Photoshop counterpart):
• Perform your changes in Lightroom, then send the RAW file over to Photoshop as a 

Smart Object
• Right-click on the smart object and select Duplicate Layer
• Select the original PSD document as the destination, replace the existing image 

smart object layer with the newly duplicated layer and save

• Resources
• https://creativeraw.com/lightroom-to-photoshop-roundtrip/
• https://www.youtube.com/watch?v=zgMI0hmfclE&ab_channel=photoshopCAFE

https://creativeraw.com/lightroom-to-photoshop-roundtrip/
https://www.youtube.com/watch?v=zgMI0hmfclE&ab_channel=photoshopCAFE


Resources

• https://creativeraw.com/lightroom-to-photoshop-roundtrip/

• https://www.youtube.com/watch?v=zgMI0hmfclE&ab_channel=photoshopCAFE

• https://petapixel.com/2020/02/05/there-and-back-again-sending-photos-between-
lightroom-and-photoshop/

• https://tutvid.com/lightroom/roundtrip-lightroom-photoshop-editing-workflow/

• https://www.adobe.com/max/2020/sessions/lightroom-classic-part-3-roundtripping-
sharing-and-l6421c.html

• http://www.steves-digicams.com/knowledge-center/how-tos/photo-software/how-to-
round-trip-in-lightroom.html#b

• https://www.scottdavenportphoto.com/blog/using-photoshop-smart-objects-for-round-
trip-edits-in-lightroom

• https://digital-photography-school.com/round-tripping-with-lightroom/

• https://lightroomkillertips.com/understanding-lightroom-classic-photoshop-workflow/

https://creativeraw.com/lightroom-to-photoshop-roundtrip/
https://www.youtube.com/watch?v=zgMI0hmfclE&ab_channel=photoshopCAFE
https://petapixel.com/2020/02/05/there-and-back-again-sending-photos-between-lightroom-and-photoshop/
https://tutvid.com/lightroom/roundtrip-lightroom-photoshop-editing-workflow/
https://www.adobe.com/max/2020/sessions/lightroom-classic-part-3-roundtripping-sharing-and-l6421c.html
http://www.steves-digicams.com/knowledge-center/how-tos/photo-software/how-to-round-trip-in-lightroom.html#b
https://www.scottdavenportphoto.com/blog/using-photoshop-smart-objects-for-round-trip-edits-in-lightroom
https://digital-photography-school.com/round-tripping-with-lightroom/
https://lightroomkillertips.com/understanding-lightroom-classic-photoshop-workflow/

